Native Instruments Support DAW Guides

My Native Instruments Plug-in Fails Validation in Logic Pro

TABLE OF CONTENTS

Symptom

When launching Logic Pro, the following error message appears:

Incompatible Audio Units found.

LogicMessage.png

Cause

The NI plug-in fails to be validated by Logic's Plug-in Manager due to a corrupt activation file.

Solutions

1. Check for Updates

Start Native Access and check for updates. If any product updates are available, please install them. Also make sure that the latest Logic Pro update is installed.

2. Allow Full Disk Access to Logic Pro


Please grant Full Disk Access to Logic Pro. You can find more info and the instructions in this article.

3. Rescan and Validate Plug-Ins

  1. After granting Full Disk Access to Logic Pro, restart Logic and click Start Plug-In Manager when the error message appears. You can also open the Logic Plug-In Manager from the Logic taskbar.

    LOGIC_PLUGIN_MANAGER.png

  2. Scroll to highlight the affected plug-in and click Reset & Rescan Selection.
  3. Close the Logic Plug-In Manager and reload your project.

Your Native Instruments plug-ins should now be working in Logic Pro. If the issue persists, please proceed to the next section below.

4. Further Troubleshooting

Click the Start Plug-In Manager when the error message appears. This shows which plug-ins are failing validation. Take note of the Native Instruments plug-ins that list in your plug-in manager as crashed validation. In this example, it's Maschine 2.

LOGIC_AU_MANAGER.png

Follow the steps below to resolve the issue:

  1. Open the following location on your computer:
    Macintosh HD > Users > *Username* > Library

    Note: See this article or the video below for instructions to access the hidden User Library folder on macOS.

  2. Delete the product folder for the affected plug-in from:
    Macintosh HD > Users > *Username* > Library > Application Support > Native Instruments > *Product Name* folder
  3. Delete the plist file for the affected plug-in from:
    Macintosh HD > Users > *Username* > Library > Preferences > com.native-instruments.*Product Name*.plist
  4. Delete this cache file from:
    Macintosh HD > Users > *Username* > Library > Caches > AudioUnitCache > com.apple.audiounits.cache
  5. Empty your system trash and restart the computer.

  6. Open Logic and allow it to rescan all of your AU plug-ins.

Note: The User Library is a hidden folder on macOS. To access it, click 'Go' in the Finder menu bar and hold down the 'Alt' key. The Library entry will now appear in the menu.

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