Native Instruments Support Account Support

Error Message when logging in or creating an account: "Public Data Breach"

Symptom

When trying to log in to your Native Instruments / iZotope account or trying to create one, you receive an error message explaining that the combination of your email address and password was detected in a public data breach on another website. You then receive an email with further details.


Cause

We take account security very seriously, and it’s important to us that all customer accounts remain safe. With the rise in attempts to steal login credentials, we’ve strengthened our security measures.

Login credentials found in known public data breaches will be blocked at NI / iZotope to secure your own products and data.

These steps are not meant to inconvenience you, but rather to ensure that your personal information and access remain fully protected.


To help safeguard your NI / iZotope account and products from potential theft, we proactively reach out to customers if we become aware of suspicious activities such as user account data being compromised in breaches on other websites.

Please note that Native Instruments is not the root of this issue - we're merely the messenger.


Solution

In order to unblock your account, please reset your password.


If you are trying to create an account, please simply use a different (and secure) password.

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